Start a new topic

Changing password failed. Unable to change password.

I believe the site's change password feature might be broken.  I've tried three times to change my password since I actually forgot my current one. The recovery email takes me to a page where it lets me change my password, and when I type in my new password twice, each time it has failed, returning the message "Changing password failed" with no other text or messages.

Is there anything anyone on staff can do about this?  Thanks.

we've seen this a few times but can pretty confidently swear its been fixed. this might sound weird, but can you try changing your password then using the new password you set anyways? even if it says failed. 

Tried that, unfortunately, it does not work.

Hello again.  I'm happy to say that the password change succeeded.  Maybe some kinda server hiccup or something? Needless to say I changed my password to something more memorable.  Thanks for trying, anyway, hopefully this can be resolved in the future if someone else has this issue.

Login or Signup to post a comment