Start a new topic

Iframely settings are not respected

I'm on Safari 16.2 on macOS Ventura 13.1 (Beta 2), but this issue has been ongoing since before then.

When I first started seeing the Iframely "Can we show you third party media" boxes on Cohost a few months ago, I clicked on the "Settings" box and ticked the "Trust all media providers on" box. In general, though, it seems that this doesn't work.

On the Iframe itself on an individual cohost post, the "Always for <service>" sometimes will work for a few hours, within that tab only, but later on the question will always come back.

I have not spent a lot of time playing with cohost, especially this feature, on other browsers, so I don't know if it's also broken there.

6 people have this problem

Similar problem. For example, on posts like this one:

I have tried both the "always for..." button on the post, and the settings in the settings link, and my preferences do not seem to be saved.

I experience this on iOS Safari, MacOS (Safari, Firefox), and Win 11 (Firefox), but it seems like the sort of thing that wouldn't be browser or eve OS dependent. I feel like I've tried Twitch, YouTube, and Twitter third party media.

I’m also having this issue on all my devices across multiple operating systems and browsers, Win 10 (Firefox, Chrome), iOS (Safari, Chrome, Firefox), iPadOS (Safari, Chrome, Firefox), Raspberry Pi OS (Chromium) And it affects all third party media, it’s very frustrating :-(

I have this issue as well-- whatever I select isn't obeyed.  I can't seem to get Twitter displayed, and I've been trying to turn Tiktok off for a week after accidentally allowing it through.  The settings do nothing.

I had the opposite problem! I very rarely clicked to allow an iFramely embed and don't recall ever always-allowing any website. At some point a TikTok started autoplaying without my consent and I completely disabled embeds.

Same here! On iPad, iPhone and Mac Firefox

Login or Signup to post a comment