Start a new topic

Progressive web app has no icon

Using Android 12 and Firefox 106.1, I installed the cohost web app on my home page. However, it shows up as a white box. I assume it's not pulling the right icon for the progressive web app. Attached a screenshot below. Could be just me.

10 people have this problem

Yeah this has been resolved for me for a while now, at least a few months.

1 person likes this

Is this still a problem in current versions of Firefox? I tried 120.0.1 on Android 12 (though I first saved/added the PWA icon on an unknown older version of Firefox) and it shows up as grey text on a red oval on a white squircle, just like the favicon on desktop.

Don't quote me on this one but I tried downloading the app icons in Cohost's PWA manifest (at and found that both of the icons that it refers to are images with zero data whatsoever. Maybe Chrome is pulling from the apple-touch-icon in the page's header instead as a fallback and that's why it shows up fine in that browser.

1 person likes this

seems to be a firefox thing, i'm having the same issue! chromium browsers function normally

Still an issue on the latest Firefox mobile (109.1.1)

Also having the same issue. No idea why the page can be viewed in a private tab but nor a normal tab.

This would be nice to see updated!

I see the same issue on Android 13 and firefox 106.1.0

3 people like this
Login or Signup to post a comment